lkml.org 
[lkml]   [2023]   [Mar]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 1/3] watchdog: s3c2410_wdt: Fold s3c2410_get_wdt_drv_data() into only caller
From
On 3/6/23 09:47, Uwe Kleine-König wrote:
> On Mon, Mar 06, 2023 at 09:17:23AM -0800, Guenter Roeck wrote:
>> On 3/6/23 01:09, Uwe Kleine-König wrote:
>>> s3c2410_get_wdt_drv_data() is only called by s3c2410wdt_probe(), so the
>>> implementation of the former can move to the latter.
>>>
>>> scripts/bloat-o-meter reports for this change (on an ARCH=arm
>>> allmodconfig build):
>>>
>>> add/remove: 1/1 grow/shrink: 0/2 up/down: 4/-129 (-125)
>>>
>>
>> The reason for separating functions in this case wasn't that the separate function
>> would be called several times. It was to improve code readability. If anything,
>> I would argue that it might sense to split the already lengthy probe function
>> further instead of combining it.
>
> Agreed. For dev_err_probe() to work the following would be alternatively
> possible:
>

That looks ok to me.

Thanks,
Guenter

> diff --git a/drivers/watchdog/s3c2410_wdt.c b/drivers/watchdog/s3c2410_wdt.c
> index 58b262ca4e88..564919717761 100644
> --- a/drivers/watchdog/s3c2410_wdt.c
> +++ b/drivers/watchdog/s3c2410_wdt.c
> @@ -579,8 +579,8 @@ static inline unsigned int s3c2410wdt_get_bootstatus(struct s3c2410_wdt *wdt)
> return 0;
> }
>
> -static inline const struct s3c2410_wdt_variant *
> -s3c2410_get_wdt_drv_data(struct platform_device *pdev)
> +static inline int
> +s3c2410_get_wdt_drv_data(struct platform_device *pdev, struct s3c2410_wdt *wdt)
> {
> const struct s3c2410_wdt_variant *variant;
> struct device *dev = &pdev->dev;
> @@ -603,24 +603,26 @@ s3c2410_get_wdt_drv_data(struct platform_device *pdev)
> "samsung,cluster-index", &index);
> if (err) {
> dev_err(dev, "failed to get cluster index\n");
> - return NULL;
> + return -EINVAL;
> }
>
> switch (index) {
> case 0:
> - return variant;
> + break;
> case 1:
> - return (variant == &drv_data_exynos850_cl0) ?
> + variant = (variant == &drv_data_exynos850_cl0) ?
> &drv_data_exynos850_cl1 :
> &drv_data_exynosautov9_cl1;
> + break;
> default:
> dev_err(dev, "wrong cluster index: %u\n", index);
> - return NULL;
> + return -EINVAL;
> }
> }
> #endif
> + wdt->drv_data = variant;
>
> - return variant;
> + return 0;
> }
>
> static void s3c2410wdt_wdt_disable_action(void *data)
> @@ -644,9 +646,9 @@ static int s3c2410wdt_probe(struct platform_device *pdev)
> spin_lock_init(&wdt->lock);
> wdt->wdt_device = s3c2410_wdd;
>
> - wdt->drv_data = s3c2410_get_wdt_drv_data(pdev);
> - if (!wdt->drv_data)
> - return -EINVAL;
> + ret = s3c2410_get_wdt_drv_data(pdev, wdt);
> + if (ret)
> + return ret;
>
> if (wdt->drv_data->quirks & QUIRKS_HAVE_PMUREG) {
> wdt->pmureg = syscon_regmap_lookup_by_phandle(dev->of_node,
>
> I didn't check if it's the same as for my initial patch #1, but for an
> allmodconfig ARCH=arm build this also has a nice bloatometer output:
>
> add/remove: 1/1 grow/shrink: 0/1 up/down: 4/-104 (-100)
>
> This would allow to make use of dev_err_probe() in
> s3c2410_get_wdt_drv_data() and still maintain the split into two
> functions.
>
> Best regards
> Uwe
>

\
 
 \ /
  Last update: 2023-03-27 00:46    [W:0.043 / U:0.584 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site