lkml.org 
[lkml]   [2023]   [Mar]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v7 6/6] PCI: Make use of pci_resource_n()
From
On 23/3/23 18:36, Andy Shevchenko wrote:
> Replace open-coded implementations of pci_resource_n() in pci.h.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> ---
> include/linux/pci.h | 14 ++++++--------
> 1 file changed, 6 insertions(+), 8 deletions(-)
>
> diff --git a/include/linux/pci.h b/include/linux/pci.h
> index 70a4684d5f26..9539cf63fe5e 100644
> --- a/include/linux/pci.h
> +++ b/include/linux/pci.h
> @@ -2006,14 +2006,12 @@ int pci_iobar_pfn(struct pci_dev *pdev, int bar, struct vm_area_struct *vma);
> * for accessing popular PCI BAR info
> */
> #define pci_resource_n(dev, bar) (&(dev)->resource[(bar)])
> -#define pci_resource_start(dev, bar) ((dev)->resource[(bar)].start)
> -#define pci_resource_end(dev, bar) ((dev)->resource[(bar)].end)
> -#define pci_resource_flags(dev, bar) ((dev)->resource[(bar)].flags)
> -#define pci_resource_len(dev,bar) \
> - ((pci_resource_end((dev), (bar)) == 0) ? 0 : \
> - \
> - (pci_resource_end((dev), (bar)) - \
> - pci_resource_start((dev), (bar)) + 1))
> +#define pci_resource_start(dev, bar) (pci_resource_n(dev, bar)->start)
> +#define pci_resource_end(dev, bar) (pci_resource_n(dev, bar)->end)
> +#define pci_resource_flags(dev, bar) (pci_resource_n(dev, bar)->flags)
> +#define pci_resource_len(dev,bar) \
> + (pci_resource_end((dev), (bar)) ? \
> + resource_size(pci_resource_n((dev), (bar))) : 0)

Seems (to me) more logical to have this patch as "PCI: Introduce
pci_resource_n()" ordered before your patch #2 "PCI: Introduce
pci_dev_for_each_resource()".

Here as #6 or as #2:
Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>

\
 
 \ /
  Last update: 2023-03-27 01:16    [W:0.091 / U:0.944 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site