lkml.org 
[lkml]   [2023]   [Mar]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 2/2] usb: pci-quirks: Remove a useless initialization
From

Le 23/03/2023 à 17:32, Greg Kroah-Hartman a écrit :
> On Tue, Mar 21, 2023 at 10:43:10PM +0100, Christophe JAILLET wrote:
>> 'info' is memset()'ed a few lines below and is not use in the between.
>>
>> There is no need to initialize one of its field to false here.
>>
>> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
>> ---
>> drivers/usb/host/pci-quirks.c | 1 -
>> 1 file changed, 1 deletion(-)
>>
>> diff --git a/drivers/usb/host/pci-quirks.c b/drivers/usb/host/pci-quirks.c
>> index 6b741327d2c4..46f2412dcb40 100644
>> --- a/drivers/usb/host/pci-quirks.c
>> +++ b/drivers/usb/host/pci-quirks.c
>> @@ -208,7 +208,6 @@ static void usb_amd_find_chipset_info(void)
>> {
>> unsigned long flags;
>> struct amd_chipset_info info;
>> - info.need_pll_quirk = false;
> Why not just change the line above it to:
> struct amd_chipset_info info = { };
> and drop the call to memset entirely?

I find an explicit memset() more readable, but it's mostly a matter of
taste.

I'll send a v2.

CJ


> thanks,
>
> greg k-h

\
 
 \ /
  Last update: 2023-03-27 01:15    [W:0.036 / U:0.364 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site