lkml.org 
[lkml]   [2023]   [Dec]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    From
    SubjectRe: [PATCH RFC v3 05/21] ACPI: Rename ACPI_HOTPLUG_CPU to include 'present'
    On Wed, 13 Dec 2023 12:49:37 +0000
    Russell King (Oracle) <rmk+kernel@armlinux.org.uk> wrote:

    > From: James Morse <james.morse@arm.com>
    >
    > The code behind ACPI_HOTPLUG_CPU allows a not-present CPU to become
    > present. This isn't the only use of HOTPLUG_CPU. On arm64 and riscv
    > CPUs can be taken offline as a power saving measure.
    >
    > On arm64 an offline CPU may be disabled by firmware, preventing it from
    > being brought back online, but it remains present throughout.
    >
    > Adding code to prevent user-space trying to online these disabled CPUs
    > needs some additional terminology.
    >
    > Rename the Kconfig symbol CONFIG_ACPI_HOTPLUG_PRESENT_CPU to reflect
    > that it makes possible CPUs present.
    >
    > HOTPLUG_CPU is untouched as this is only about the ACPI mechanism.
    >
    > Signed-off-by: James Morse <james.morse@arm.com>
    > Tested-by: Miguel Luis <miguel.luis@oracle.com>
    > Tested-by: Vishnu Pajjuri <vishnu@os.amperecomputing.com>
    > Tested-by: Jianyong Wu <jianyong.wu@arm.com>
    > Signed-off-by: Russell King (Oracle) <rmk+kernel@armlinux.org.uk>
    Formatting nitpick inline. Either way FWIW:
    Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>

    > diff --git a/include/linux/acpi.h b/include/linux/acpi.h
    > index 4db54e928b36..36071bc11acd 100644
    > --- a/include/linux/acpi.h
    > +++ b/include/linux/acpi.h

    > #ifdef CONFIG_ACPI_HOTPLUG_IOAPIC
    > int acpi_get_ioapic_id(acpi_handle handle, u32 gsi_base, u64 *phys_addr);
    > @@ -629,7 +629,7 @@ static inline u32 acpi_osc_ctx_get_cxl_control(struct acpi_osc_context *context)
    > #define ACPI_GSB_ACCESS_ATTRIB_RAW_PROCESS 0x0000000F
    >
    > /* Enable _OST when all relevant hotplug operations are enabled */
    > -#if defined(CONFIG_ACPI_HOTPLUG_CPU) && \
    > +#if defined(CONFIG_ACPI_HOTPLUG_PRESENT_CPU) && \

    Trivial but I think there is a tab to many before that \

    > defined(CONFIG_ACPI_HOTPLUG_MEMORY) && \
    > defined(CONFIG_ACPI_CONTAINER)
    > #define ACPI_HOTPLUG_OST

    \
     
     \ /
      Last update: 2023-12-14 20:22    [W:8.200 / U:0.088 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site