lkml.org 
[lkml]   [2023]   [Oct]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 1/7] topology: add a new arch_scale_freq_reference

* Vincent Guittot <vincent.guittot@linaro.org> wrote:

> --- a/include/linux/arch_topology.h
> +++ b/include/linux/arch_topology.h
> @@ -27,6 +27,13 @@ static inline unsigned long topology_get_cpu_scale(int cpu)
>
> void topology_set_cpu_scale(unsigned int cpu, unsigned long capacity);
>
> +DECLARE_PER_CPU(unsigned long, capacity_ref_freq);
> +
> +static inline unsigned long topology_get_freq_ref(int cpu)
> +{
> + return per_cpu(capacity_ref_freq, cpu);
> +}
> +
> DECLARE_PER_CPU(unsigned long, arch_freq_scale);

So mind naming it in a way that expresses that this is indeed a maximum
frequency? arch_scale_ref_freq_max or so?

Also, is there any particular concept behind naming one new symbol
'freq_ref', the other 'ref_freq'? If not then please standardize on one
variant.

Thanks,

Ingo

\
 
 \ /
  Last update: 2023-10-27 11:31    [W:0.453 / U:0.160 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site