lkml.org 
[lkml]   [2023]   [Oct]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH v3 7/9] tty/serial: Add RISC-V SBI debug console based earlycon
    On Fri, Oct 20, 2023 at 12:51:38PM +0530, Anup Patel wrote:
    > We extend the existing RISC-V SBI earlycon support to use the new
    > RISC-V SBI debug console extension.
    >
    > Signed-off-by: Anup Patel <apatel@ventanamicro.com>
    > Reviewed-by: Andrew Jones <ajones@ventanamicro.com>
    > ---
    > drivers/tty/serial/Kconfig | 2 +-
    > drivers/tty/serial/earlycon-riscv-sbi.c | 32 +++++++++++++++++++++----
    > 2 files changed, 29 insertions(+), 5 deletions(-)
    >
    > diff --git a/drivers/tty/serial/Kconfig b/drivers/tty/serial/Kconfig
    > index bdc568a4ab66..cec46091a716 100644
    > --- a/drivers/tty/serial/Kconfig
    > +++ b/drivers/tty/serial/Kconfig
    > @@ -87,7 +87,7 @@ config SERIAL_EARLYCON_SEMIHOST
    >
    > config SERIAL_EARLYCON_RISCV_SBI
    > bool "Early console using RISC-V SBI"
    > - depends on RISCV_SBI_V01
    > + depends on RISCV_SBI
    > select SERIAL_CORE
    > select SERIAL_CORE_CONSOLE
    > select SERIAL_EARLYCON
    > diff --git a/drivers/tty/serial/earlycon-riscv-sbi.c b/drivers/tty/serial/earlycon-riscv-sbi.c
    > index 27afb0b74ea7..c21cdef254e7 100644
    > --- a/drivers/tty/serial/earlycon-riscv-sbi.c
    > +++ b/drivers/tty/serial/earlycon-riscv-sbi.c
    > @@ -15,17 +15,41 @@ static void sbi_putc(struct uart_port *port, unsigned char c)
    > sbi_console_putchar(c);
    > }
    >
    > -static void sbi_console_write(struct console *con,
    > - const char *s, unsigned n)
    > +static void sbi_0_1_console_write(struct console *con,
    > + const char *s, unsigned int n)
    > {
    > struct earlycon_device *dev = con->data;
    > uart_console_write(&dev->port, s, n, sbi_putc);
    > }
    >
    > +static void sbi_dbcn_console_write(struct console *con,
    > + const char *s, unsigned int n)
    > +{
    > + phys_addr_t pa = __pa(s);
    > +
    > + if (IS_ENABLED(CONFIG_32BIT))
    > + sbi_ecall(SBI_EXT_DBCN, SBI_EXT_DBCN_CONSOLE_WRITE,
    > + n, lower_32_bits(pa), upper_32_bits(pa), 0, 0, 0);
    > + else
    > + sbi_ecall(SBI_EXT_DBCN, SBI_EXT_DBCN_CONSOLE_WRITE,
    > + n, pa, 0, 0, 0, 0);

    This is still a bit hard to follow, and I guarantee it will be a pain to
    maintain over time, trying to keep both calls in sync, right?

    Why not fix up sbi_ecall() to get this correct instead? It should be
    handling phys_addr_t values, not forcing you to do odd bit masking every
    single time you call it, right? That would make things much easier
    overall, and this patch simpler, as well as the next one.

    Oh wait, sbi_ecall() is crazy, and just a pass-through, so that's not
    going to work, you need a wrapper function for this mess to do that bit
    twiddeling for you instead of forcing you to do it each time, I guess
    that's what you are trying to do here, but ick, is it correct?

    thanks,

    greg k-h

    \
     
     \ /
      Last update: 2023-10-21 18:47    [W:3.974 / U:0.560 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site