lkml.org 
[lkml]   [2023]   [Oct]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH] tty: gdm724x: Fix coding style checkpatch warnings
    On Thu, Oct 12, 2023 at 10:14:58PM -0700, Soumya Negi wrote:
    > @@ -271,8 +272,8 @@ int register_lte_tty_driver(void)
    > int ret;
    >
    > for (i = 0; i < TTY_MAX_COUNT; i++) {
    > - tty_driver = tty_alloc_driver(GDM_TTY_MINOR,
    > - TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV);
    > + tty_driver = tty_alloc_driver(GDM_TTY_MINOR, TTY_DRIVER_REAL_RAW |
    > + TTY_DRIVER_DYNAMIC_DEV);

    Don't do this. The code was better before. The parameter
    "TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV" is one thing and
    splitting it up like that makes the code less readable. And I bet they
    had to indent it like that to get under the 80 character limit.

    This is an example of checkpatch giving bad advice.

    regards,
    dan carpenter

    \
     
     \ /
      Last update: 2023-10-13 10:54    [W:4.940 / U:0.160 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site