lkml.org 
[lkml]   [2023]   [Oct]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v1 1/1] hte: Use kasprintf() instead of fixed buffer formatting
From
On 10/10/23 7:11 AM, Andy Shevchenko wrote:
> Improve readability and maintainability by replacing a hardcoded string
> allocation and formatting by the use of the kasprintf() helper.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> ---
> drivers/hte/hte.c | 13 ++++---------
> 1 file changed, 4 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/hte/hte.c b/drivers/hte/hte.c
> index 1fd8d2d4528b..23a6eeb8c506 100644
> --- a/drivers/hte/hte.c
> +++ b/drivers/hte/hte.c
> @@ -17,8 +17,6 @@
> #include <linux/debugfs.h>
> #include <linux/device.h>
>
> -#define HTE_TS_NAME_LEN 10
> -
> /* Global list of the HTE devices */
> static DEFINE_SPINLOCK(hte_lock);
> static LIST_HEAD(hte_devices);
> @@ -389,13 +387,10 @@ static int __hte_req_ts(struct hte_ts_desc *desc, hte_ts_cb_t cb,
>
> atomic_inc(&gdev->ts_req);
>
> - ei->line_name = NULL;
> - if (!desc->attr.name) {
> - ei->line_name = kzalloc(HTE_TS_NAME_LEN, GFP_KERNEL);
> - if (ei->line_name)
> - scnprintf(ei->line_name, HTE_TS_NAME_LEN, "ts_%u",
> - desc->attr.line_id);
> - }
> + if (desc->attr.name)
> + ei->line_name = NULL;
> + else
> + ei->line_name = kasprintf(GFP_KERNEL, "ts_%u", desc->attr.line_id);
>
> hte_ts_dbgfs_init(desc->attr.name == NULL ?
> ei->line_name : desc->attr.name, ei);
Reviewed-by: Dipen Patel <dipenp@nvidia.com>

\
 
 \ /
  Last update: 2023-10-10 18:13    [W:0.098 / U:0.708 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site