lkml.org 
[lkml]   [2023]   [Oct]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH RFC v4 6/6] input: ads7846: Move wait_for_sync() logic to driver
On Sun, Oct 1, 2023 at 5:13 PM Duje Mihanović <duje.mihanovic@skole.hr> wrote:
>
> If this code is left in the board file, the sync GPIO would have to be
> separated into another lookup table during conversion to the GPIO
> descriptor API (which is also done in this patch).
>
> The only user of this code (Sharp Spitz) is also converted in this
> patch.

Suggested-by: Linus... ?

...

> +static void ads7846_wait_for_sync(struct ads7846 *ts)

I would name it ..._wait_for_sync_gpio.

...

> + ts->sync = devm_gpiod_get_optional(dev, "sync", GPIOD_IN);
> + if (IS_ERR(ts->sync)) {

> + dev_err(dev, "Failed to get sync GPIO: %pe\n", ts->sync);
> + return PTR_ERR(ts->sync);

return dev_err_probe(...); ?

> + }

--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2023-10-01 16:57    [W:0.244 / U:0.588 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site