lkml.org 
[lkml]   [2023]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH bpf-next v3 4/4] bpf/selftests: Verify struct_ops prog sleepable behavior
On Wed, Jan 25, 2023 at 08:06:11AM -0800, Alexei Starovoitov wrote:
> On Tue, Jan 24, 2023 at 9:04 PM David Vernet <void@manifault.com> wrote:
> >
> > In a set of prior changes, we added the ability for struct_ops programs
> > to be sleepable. This patch enhances the dummy_st_ops selftest suite to
> > validate this behavior by adding a new sleepable struct_ops entry to
> > dummy_st_ops.
> >
> > Signed-off-by: David Vernet <void@manifault.com>
> > ---
> > include/linux/bpf.h | 1 +
> > net/bpf/bpf_dummy_struct_ops.c | 18 +++++++
> > .../selftests/bpf/prog_tests/dummy_st_ops.c | 54 ++++++++++++++-----
> > .../selftests/bpf/progs/dummy_st_ops_fail.c | 27 ++++++++++
> > ...{dummy_st_ops.c => dummy_st_ops_success.c} | 19 +++----
> > 5 files changed, 94 insertions(+), 25 deletions(-)
> > create mode 100644 tools/testing/selftests/bpf/progs/dummy_st_ops_fail.c
> > rename tools/testing/selftests/bpf/progs/{dummy_st_ops.c => dummy_st_ops_success.c} (72%)
>
> It fails on s390:
> dummy_st_ops_success/dummy_multiple_args:FAIL
>
> Please add to DENYLIST as part of this patch.

Sorry, this was just a dumb replace-all mistake on my part -- accidentally
changed the name of the testsuite to dummy_st_ops_success when changing the
name of the BPF prog in prog_tests/dummy_st_ops. It's already in the DENYLIST.
This should fix it:

diff --git a/tools/testing/selftests/bpf/prog_tests/dummy_st_ops.c b/tools/testing/selftests/bpf/prog_tests/dummy_st_ops.c
index 135514fad83a..f43fcb13d2c4 100644
--- a/tools/testing/selftests/bpf/prog_tests/dummy_st_ops.c
+++ b/tools/testing/selftests/bpf/prog_tests/dummy_st_ops.c
@@ -144,7 +144,7 @@ static void test_dummy_sleepable(void)
dummy_st_ops_success__destroy(skel);
}

-void test_dummy_st_ops_success(void)
+void test_dummy_st_ops(void)
{
if (test__start_subtest("dummy_st_ops_attach"))
test_dummy_st_ops_attach();

Will send out the v4 with that fix shortly.

\
 
 \ /
  Last update: 2023-03-26 23:55    [W:0.033 / U:0.756 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site