lkml.org 
[lkml]   [2021]   [Feb]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 03/10] mm: don't pass "enum lru_list" to lru list addition functions
On Tue, 26 Jan 2021 15:14:38 -0700 Yu Zhao <yuzhao@google.com> wrote:

> On Tue, Jan 26, 2021 at 10:01:11PM +0000, Matthew Wilcox wrote:
> > On Fri, Jan 22, 2021 at 03:05:53PM -0700, Yu Zhao wrote:
> > > +++ b/mm/swap.c
> > > @@ -231,7 +231,7 @@ static void pagevec_move_tail_fn(struct page *page, struct lruvec *lruvec)
> > > if (!PageUnevictable(page)) {
> > > del_page_from_lru_list(page, lruvec, page_lru(page));
> > > ClearPageActive(page);
> > > - add_page_to_lru_list_tail(page, lruvec, page_lru(page));
> > > + add_page_to_lru_list_tail(page, lruvec);
> > > __count_vm_events(PGROTATED, thp_nr_pages(page));
> > > }
> >
> > Is it profitable to do ...
> >
> > - del_page_from_lru_list(page, lruvec, page_lru(page));
> > + enum lru_list lru = page_lru(page);
> > + del_page_from_lru_list(page, lruvec, lru);
> > ClearPageActive(page);
> > - add_page_to_lru_list_tail(page, lruvec, page_lru(page));
> > + lru &= ~LRU_ACTIVE;
> > + add_page_to_lru_list_tail(page, lruvec, lru);
>
> Ok, now we want to trade readability for size. Sure, I'll see how
> much we could squeeze.

As nothing has happened here and the code bloat issue remains, I'll
hold this series out of 5.12-rc1.

\
 
 \ /
  Last update: 2021-02-24 00:03    [W:0.305 / U:0.316 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site