lkml.org 
[lkml]   [2020]   [Jun]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
    Date


    On 6/16/20 9:53 PM, Joe Perches wrote:
    > On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote:
    >> v4:
    >> - Break out the memzero_explicit() change as suggested by Dan Carpenter
    >> so that it can be backported to stable.
    >> - Drop the "crypto: Remove unnecessary memzero_explicit()" patch for
    >> now as there can be a bit more discussion on what is best. It will be
    >> introduced as a separate patch later on after this one is merged.
    >
    > To this larger audience and last week without reply:
    > https://lore.kernel.org/lkml/573b3fbd5927c643920e1364230c296b23e7584d.camel@perches.com/
    >
    > Are there _any_ fastpath uses of kfree or vfree?
    >
    > Many patches have been posted recently to fix mispairings
    > of specific types of alloc and free functions.

    I've prepared a coccinelle script to highlight these mispairings in a function
    a couple of days ago: https://lkml.org/lkml/2020/6/5/953
    I've listed all the fixes in the commit message.

    Not so many mispairings actually, and most of them are harmless like:
    kmalloc(E) -> kvfree(E)

    However, coccinelle script can't detect cross-functions mispairings, i.e.
    allocation in one function, free in another funtion.

    Thanks,
    Denis

    \
     
     \ /
      Last update: 2020-06-17 23:38    [W:5.138 / U:0.024 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site