lkml.org 
[lkml]   [2019]   [Aug]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    SubjectRe: [PATCH v3] mailbox: imx: add support for imx v1 mu
    One more thing. See below:

    On Wed, Jul 31, 2019 at 12:14 PM Richard Zhu <hongxing.zhu@nxp.com> wrote:

    <snip>

    > -/* Control Register */
    > -#define IMX_MU_xCR 0x24
    > /* General Purpose Interrupt Enable */
    > #define IMX_MU_xCR_GIEn(x) BIT(28 + (3 - (x)))
    > /* Receive Interrupt Enable */
    > @@ -44,6 +36,13 @@ enum imx_mu_chan_type {
    > IMX_MU_TYPE_RXDB, /* Rx doorbell */
    > };
    >
    > +struct imx_mu_dcfg {

    Can you rename this into imx_mu_regs ?

    > + u32 xTR[4]; /* Transmit Registers */
    > + u32 xRR[4]; /* Receive Registers */
    > + u32 xSR; /* Status Register */
    > + u32 xCR; /* Control Register */
    > +};

    \
     
     \ /
      Last update: 2019-08-02 05:55    [W:2.710 / U:0.028 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site