lkml.org 
[lkml]   [2019]   [Jan]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[RFC v6 0/4] pstore/block: new support logger for block devices
Date
Why should we need pstore_block?
1. Most embedded intelligent equipment have no persistent ram, which
increases costs. We perfer to cheaper solutions, like block devices.
In fast, there is already a sample for block device logger in driver
MTD (drivers/mtd/mtdoops.c).
2. Do not any equipment have battery, which means that it lost all data
on general ram if power failure. Pstore has little to do for these
equipments.

[PATCH v6]
On patch 1:
1. Fix according to email from Kees Cook, including spelling mistakes, explicit
overflow test, none of the zeroing etc.
2. Do not recover data but metadata of dmesg when panic.
3. No need to take recovery when do erase.
4. Do not use "blkoops" for blkzone any more because "blkoops" is used for other
module now.(rename blkbuf to blkoops)
On patch 2:
1. Rename blkbuf to blkoops.
2. Add Kconfig/device tree/module parameters settings for blkoops.
3. Add document for device tree.
On patch 3:
1. Blkoops support pmsg.
2. Fix description for new version patch.
On patch 4:
1. Fix description for new version patch.

[PATCH v5]
On patch 1:
1. rename pstore/rom to pstore/blk
2. Do not allocate any memory in the write path of panic. So, use local
array instead in function romz_recover_dmesg_meta.
3. Add C header file "linux/fs.h" to fix implicit declaration of function
'filp_open','kernel_read'...
On patch 3:
1. If panic, do not recover pmsg but flush if it is dirty.
2. Fix erase pmsg failed.
On patch 4:
1. Create a document for pstore/blk

[PATCH v4]
On patch 1:
1. Fix always true condition '(--i >= 0) => (0-u32max >= 0)' in function
romz_init_zones by defining variable i to 'int' rahter than
'unsigned int'.
2. To make codes more easily to read, we use macro READ_NEXT_ZONE for
return value of romz_dmesg_read if it need to read next zone.
Moveover, we assign READ_NEXT_ZONE -1024 rather than 0.
3. Add 'FLUSH_META' to 'enum romz_flush_mode' and rename 'NOT_FLUSH' to
'FLUSH_NONE'
4. Function romz_zone_write work badly with FLUSH_PART mode as badly
address and offset to write.
On patch 3:
NEW SUPPORT psmg for pstore_rom.

[PATCH v3]
On patch 1:
Fix build as module error for undefined 'vfs_read' and 'vfs_write'
Both of 'vfs_read' and 'vfs_write' haven't be exproted yet, so we use
'kernel_read' and 'kernel_write' instead.

[PATCH v2]
On patch 1:
Fix build as module error for redefinition of 'romz_unregister' and
'romz_register'

[PATCH v1]
On patch 1:
Core codes of pstore_rom, which works well on allwinner(sunxi) platform.
On patch 2:
A sample for pstore_rom, using general ram rather than block device.

liaoweixiong (4):
pstore/blk: new support logger for block devices
pstore/blk: add blkoops for pstore_blk
pstore/blk: support pmsg for pstore block
Documentation: pstore/blk: create document for pstore_blk

Documentation/admin-guide/pstore-block.rst | 227 ++++
.../devicetree/bindings/pstore-block/blkoops.txt | 32 +
MAINTAINERS | 4 +-
fs/pstore/Kconfig | 128 +++
fs/pstore/Makefile | 5 +
fs/pstore/blkoops.c | 250 +++++
fs/pstore/blkzone.c | 1163 ++++++++++++++++++++
include/linux/pstore_blk.h | 62 ++
8 files changed, 1870 insertions(+), 1 deletion(-)
create mode 100644 Documentation/admin-guide/pstore-block.rst
create mode 100644 Documentation/devicetree/bindings/pstore-block/blkoops.txt
create mode 100644 fs/pstore/blkoops.c
create mode 100644 fs/pstore/blkzone.c
create mode 100644 include/linux/pstore_blk.h

--
1.9.1

\
 
 \ /
  Last update: 2019-01-23 12:02    [W:0.227 / U:0.268 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site