lkml.org 
[lkml]   [2018]   [Jun]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v6 02/11] sched/pelt: remove blank line
On Thu, 21 Jun 2018 at 16:33, Peter Zijlstra <peterz@infradead.org> wrote:
>
> On Fri, Jun 08, 2018 at 02:09:45PM +0200, Vincent Guittot wrote:
> > diff --git a/kernel/sched/pelt.c b/kernel/sched/pelt.c
> > index e6ecbb2..4174582 100644
> > --- a/kernel/sched/pelt.c
> > +++ b/kernel/sched/pelt.c
> > @@ -287,7 +287,6 @@ int __update_load_avg_se(u64 now, int cpu, struct cfs_rq *cfs_rq, struct sched_e
> >
> > if (___update_load_sum(now, cpu, &se->avg, !!se->on_rq, !!se->on_rq,
> > cfs_rq->curr == se)) {
> > -
> > ___update_load_avg(&se->avg, se_weight(se), se_runnable(se));
> > cfs_se_util_change(&se->avg);
> > return 1;
> > @@ -302,7 +301,6 @@ int __update_load_avg_cfs_rq(u64 now, int cpu, struct cfs_rq *cfs_rq)
> > scale_load_down(cfs_rq->load.weight),
> > scale_load_down(cfs_rq->runnable_weight),
> > cfs_rq->curr != NULL)) {
> > -
> > ___update_load_avg(&cfs_rq->avg, 1, 1);
> > return 1;
> > }
>
> So I put them there on purpose, I find it easier to read when a
> multi-line if statement and the body are separated. Makes it clearer
> where the if ends and the block begins.
>
> I mean, all whitespace in C is superfluous, and yet we keep adding it to
> these files :-)

I'm fine with keeping it as well as for newly added ones; Patrick
raised the point on a similar empty line for the newly added
update_rt_rq_load_avg() function on previous revision and just wanted
to keep them all aligned

\
 
 \ /
  Last update: 2018-06-21 20:43    [W:1.567 / U:0.764 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site