lkml.org 
[lkml]   [2018]   [Apr]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3 1/3] resource: Use list_head to link resource sibling
On 04/09/18 at 08:38am, Dan Williams wrote:
> On Mon, Apr 9, 2018 at 2:08 AM, Baoquan He <bhe@redhat.com> wrote:
> > The struct resource uses singly linked list to link siblings. It's not
> > easy to do reverse iteration on sibling list. So replace it with list_head.
> >
> > And code refactoring makes codes in kernel/resource.c more readable than
> > pointer operation.
> >
> > Besides, type of member variables of struct resource, sibling and child, are
> > changed from 'struct resource *' to 'struct list_head'. Kernel size will
> > increase because of those statically defined struct resource instances.
> >
> > Signed-off-by: Baoquan He <bhe@redhat.com>
> > ---
> [..]
> > diff --git a/kernel/resource.c b/kernel/resource.c
> > index e270b5048988..473c624606f9 100644
> > --- a/kernel/resource.c
> > +++ b/kernel/resource.c
> > @@ -31,6 +31,8 @@ struct resource ioport_resource = {
> > .start = 0,
> > .end = IO_SPACE_LIMIT,
> > .flags = IORESOURCE_IO,
> > + .sibling = LIST_HEAD_INIT(ioport_resource.sibling),
> > + .child = LIST_HEAD_INIT(ioport_resource.child),
> > };
> > EXPORT_SYMBOL(ioport_resource);
> >
> > @@ -39,6 +41,8 @@ struct resource iomem_resource = {
> > .start = 0,
> > .end = -1,
> > .flags = IORESOURCE_MEM,
> > + .sibling = LIST_HEAD_INIT(iomem_resource.sibling),
> > + .child = LIST_HEAD_INIT(iomem_resource.child),
> > };
> > EXPORT_SYMBOL(iomem_resource);
> >
> > @@ -57,20 +61,32 @@ static DEFINE_RWLOCK(resource_lock);
> > * by boot mem after the system is up. So for reusing the resource entry
> > * we need to remember the resource.
> > */
> > -static struct resource *bootmem_resource_free;
> > +static struct list_head bootmem_resource_free = LIST_HEAD_INIT(bootmem_resource_free);
> > static DEFINE_SPINLOCK(bootmem_resource_lock);
> >
> > +struct resource *sibling(struct resource *res)
> > +{
> > + if (res->parent && !list_is_last(&res->sibling, &res->parent->child))
> > + return list_next_entry(res, sibling);
> > + return NULL;
> > +}
> > +
> > +struct resource *first_child(struct list_head *head)
> > +{
> > + return list_first_entry_or_null(head, struct resource, sibling);
> > +}
> > +
>
> These names are too generic for new global symbols. A "resource_"
> prefix is warranted.

Thanks, sounds reasonable, will change them as resource_sibling() and
resource_first_child(). Or res_sibling()/res_1st_child()?

\
 
 \ /
  Last update: 2018-04-10 04:11    [W:0.069 / U:0.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site