lkml.org 
[lkml]   [2018]   [Feb]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] mm/swap.c: make functions and their kernel-doc agree (again)
From
Date
On 02/08/2018 11:09 AM, Mike Rapoport wrote:
> There was a conflict between the commit e02a9f048ef7 ("mm/swap.c: make
> functions and their kernel-doc agree") and the commit f144c390f905 ("mm:
> docs: fix parameter names mismatch") that both tried to fix mismatch
> betweeen pagevec_lookup_entries() parameter names and their description.
>
> Since nr_entries is a better name for the parameter, fix the description
> again.
>
> Signed-off-by: Mike Rapoport <rppt@linux.vnet.ibm.com>

Thanks, I hadn't noticed.

Acked-by: Randy Dunlap <rdunlap@infradead.org>


> ---
> mm/swap.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/mm/swap.c b/mm/swap.c
> index 567a7b96e41d..6d7b8bc58003 100644
> --- a/mm/swap.c
> +++ b/mm/swap.c
> @@ -913,7 +913,7 @@ EXPORT_SYMBOL(__pagevec_lru_add);
> * @pvec: Where the resulting entries are placed
> * @mapping: The address_space to search
> * @start: The starting entry index
> - * @nr_pages: The maximum number of pages
> + * @nr_entries: The maximum number of pages
> * @indices: The cache indices corresponding to the entries in @pvec
> *
> * pagevec_lookup_entries() will search for and return a group of up
>


--
~Randy

\
 
 \ /
  Last update: 2018-02-08 20:17    [W:0.071 / U:0.056 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site