lkml.org 
[lkml]   [2018]   [Feb]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] mm/migrate: Rename various page allocation helper functions
On Thu, 8 Feb 2018, Anshuman Khandual wrote:
> On 02/04/2018 12:28 PM, Anshuman Khandual wrote:
> > Allocation helper functions for migrate_pages() remmain scattered with
> > similar names making them really confusing. Rename these functions based
> > on type of the intended migration. Function alloc_misplaced_dst_page()
> > remains unchanged as its highly specialized. The renamed functions are
> > listed below. Functionality of migration remains unchanged.
> >
> > 1. alloc_migrate_target -> new_page_alloc
> > 2. new_node_page -> new_page_alloc_othernode
> > 3. new_page -> new_page_alloc_keepnode
> > 4. alloc_new_node_page -> new_page_alloc_node
> > 5. new_page -> new_page_alloc_mempolicy
>
> Hello Michal/Hugh,
>
> Does the renaming good enough or we should just not rename these.

I'll neither ack nor nack, I don't greatly care: my concern was
to head you away from gathering them into a single header file.

Though alloc_new_node_page seems to me a *much* better name than
new_page_alloc_node; and I'm puzzled why you would demand this
conformity of some but not all of the functions of that type.

Hugh

\
 
 \ /
  Last update: 2018-02-08 20:14    [W:0.027 / U:1.872 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site