[lkml]   [2018]   [Feb]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 4.9 43/92] x86/pti: Do not enable PTI on CPUs which are not vulnerable to Meltdown
On Tue, Feb 13, 2018 at 03:27:47PM +0000, Nick Lowe wrote:
> Hi Arjan and Greg,
> Sorry if I am not being clear enough.
> My point is that there is a check for X86_VENDOR_AMD now in two places.
> It is still hardcoded for the auto boot option which I think should
> not be there. The patch on that basis looked incomplete to me.
> Put another way, there is no effect to the auto option where the
> contents of cpu_no_meltdown[] are changed and
> cpu_vulnerable_to_meltdown returns differently.
> The auto option does not make use of a determination of the
> This seems wrong to me. It does not seem correct to me for the auto
> option to have this duplication with a check for just X86_VENDOR_AMD.

Do you have a patch that reflects what you want to see changed here?

And can you test it? :)

I don't have any AMD hardware, sorry.


greg k-h

 \ /
  Last update: 2018-02-13 17:37    [W:0.098 / U:14.116 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site