lkml.org 
[lkml]   [2018]   [Dec]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v3 0/3] fat: Added functions to determine the FAT variant (12/16/32bit)
Date
Carmeli Tamir <carmeli.tamir@gmail.com> writes:

> Along the FAT FS code, the FAT variant (whether this is FAT12, FAT16 or FAT32) is
> determined by checking the fat_bits field of struct msdos_sb_info.
> This is somewhat error prone as it forces the usage of magics (12, 16, 32)
> multiple times in the code.
>
> This series replaces the places in which the variant is checked with three
> inline functions - IS_FAT12, IS_FAT16 and IS_FAT16.
>
> The introduction of these simple inline functions makes a clearer API for determining the variant,
> rather than searching the code for some field in a struct, and therefore
> increases the code's maintainability and readability.
>
> In addition, minor cleanups around code that checks for the FAT variant,
> and fixed comments from v1 and v2.
>
> Carmeli Tamir (3):
> Removed fat_first_ent
> Moved and inlined MAX_FAT
> IS_FAT functions
>
> fs/fat/cache.c | 2 +-
> fs/fat/dir.c | 4 ++--
> fs/fat/fat.h | 30 +++++++++++++++++++++++++++++-
> fs/fat/fatent.c | 16 +++++++---------
> fs/fat/inode.c | 26 +++++++++++++++-----------
> fs/fat/misc.c | 2 +-
> include/uapi/linux/msdos_fs.h | 5 -----
> 7 files changed, 55 insertions(+), 30 deletions(-)

FWIW,

Acked-by: OGAWA Hirofumi <hirofumi@mail.parknet.co.jp>

for all of this patchset.

Thanks.
--
OGAWA Hirofumi <hirofumi@mail.parknet.co.jp>

\
 
 \ /
  Last update: 2018-12-24 13:04    [W:0.102 / U:0.224 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site