lkml.org 
[lkml]   [2018]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Vibrations, audio, charging, radio on N9/N950
On Wednesday 03 January 2018 16:34:15 Filip Matijević wrote:
> Hi,
>
> On 01/03/2018 02:56 PM, Pavel Machek wrote:
> > Hi!
> >
> > Sebasian, you submitted patch to enable vibrations on N950. I am
> > trying to do the same now on N9... I guess I enabled the dts, but
> > .. how do I actually ask for vibrations? /dev/input/eventX does not
> > seem to be present.
> >
> > Did anyone get audio to run on N9/N950? It is marked as supported on
> > https://elinux.org/N950 with dt glue missing...
> >
>
> I have fairly recent patches (for v4.10) here:
> https://github.com/filippz/pmbootstrap/commit/600473432d8ff61ae80a7e2a198d9442fd3a6f2e
> (from 0015 trough 0022 w/o 0016). Vibration was working as was audio
> playback from twl5031 and tvl320dac33 together with tpa6140a2. More
> details here: http://talk.maemo.org/showpost.php?p=1492590&postcount=112
> I hope that you can use those patches at least to some degree.
>
> > Even more importantly, does battery charging work for someone? It does
> > not work here :-(. After USB is plugged in, it maybe tries to charge,
> > but gives up after 30 seconds.
> >
> > Maybe least important, but... does anyone have FM radio working? I'd
> > like to play some music...
>
> I haven't used FM radio nor BT (wl1273), so I can't comment on that, but
> they are in there but probably need some work.

IIRC there were some problems with FM chip on N9 or N950... something
like chip was not connected to antenna... But do not remember details.

--
Pali Rohár
pali.rohar@gmail.com

\
 
 \ /
  Last update: 2018-01-03 16:41    [W:0.023 / U:1.072 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site