lkml.org 
[lkml]   [2017]   [Sep]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v3 5/6] [media] exynos-gsc: Remove unnecessary compatible
On Fri, Sep 8, 2017 at 8:02 AM, Hoegeun Kwon <hoegeun.kwon@samsung.com> wrote:
> Currently, the compatible('samsung,exynos5-gsc') is not used.
> Remove unnecessary compatible.
>
> Signed-off-by: Hoegeun Kwon <hoegeun.kwon@samsung.com>
> ---
> Documentation/devicetree/bindings/media/exynos5-gsc.txt | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/media/exynos5-gsc.txt b/Documentation/devicetree/bindings/media/exynos5-gsc.txt
> index daa56d5..1ea05f1 100644
> --- a/Documentation/devicetree/bindings/media/exynos5-gsc.txt
> +++ b/Documentation/devicetree/bindings/media/exynos5-gsc.txt
> @@ -3,9 +3,9 @@
> G-Scaler is used for scaling and color space conversion on EXYNOS5 SoCs.
>
> Required properties:
> -- compatible: should be "samsung,exynos5-gsc" (for Exynos 5250, 5420 and
> - 5422 SoCs) or "samsung,exynos5433-gsc" (Exynos 5433)
> - or "samsung,exynos5250-gsc" or "samsung,exynos5420-gsc"
> +- compatible: should be "samsung,exynos5250-gsc", "samsung,exynos5420-gsc"
> + or "samsung,exynos5433-gsc" (for Exynos 5250, 5420, 5422,
> + and 5433 SoCs)

You should not remove the compatible (neither here nor in the driver)
but mark it as deprecated. Removal should happen slightly later.

Best regards,
Krzysztof

> - reg: should contain G-Scaler physical address location and length.
> - interrupts: should contain G-Scaler interrupt number
>
> @@ -16,7 +16,7 @@ Optional properties:
> Example:
>
> gsc_0: gsc@0x13e00000 {
> - compatible = "samsung,exynos5-gsc";
> + compatible = "samsung,exynos5250-gsc;
> reg = <0x13e00000 0x1000>;
> interrupts = <0 85 0>;
> };

\
 
 \ /
  Last update: 2017-09-08 13:25    [W:0.450 / U:1.052 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site