lkml.org 
[lkml]   [2017]   [Sep]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: mutex_lock issues during poweroff
On Thu, Sep 07, 2017 at 02:16:19PM +0200, Maxime Ripard wrote:
> One thing worth noting is that we couldn't reproduce the issue with a
> 4.13. We can't bisect really easily due to the amount of patches that
> we still have on 4.9 and have all been merged since, but it seems like
> the bug was fixed (either on purpose or as a side effect), and was
> never sent to stable. Looking at the history of kernel/locking/mutex.c
> during that window didn't really show anything obvious though.
>
> If you have any ideas or spot something very wrong, I'd be happy to
> hear about. Thanks!

Well, we did a _complete_ rewrite of the mutex primitive in v4.10-rc1.

Part of the reason for that rewrite was fixing a starvation case, but
for that you'd need to actually have contending usage, which you claim
not to have.

Aside from that I really can't remember any specific issues with the old
code (4.9 is such a long time ago). You could try to disable the
optimistic spinning code, see if that helps.

You did also say you were running on an ARM64, there were a few memory
ordering fixes like for example commit:

50972fe78f24 ("locking/osq_lock: Fix osq_lock queue corruption")

\
 
 \ /
  Last update: 2017-09-07 14:41    [W:0.191 / U:1.728 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site