lkml.org 
[lkml]   [2017]   [Sep]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC Part2 PATCH v3 01/26] Documentation/virtual/kvm: Add AMD Secure Encrypted Virtualization (SEV)
On Tue, Sep 05, 2017 at 04:39:14PM -0500, Brijesh Singh wrote:
> I was trying map with SEV firmware spec command names but I see your
> point and will call it "KVM_SEV_GET_GUEST_STATUS".
>
>
> > > +
> > > +enum {
> > > + /* guest state is not known */
> > > + SEV_STATE_INVALID = 0;
> >
> > not known or invalid?
>
>
> Again, was trying to follow the spec naming convention but I can go
> with UNKNOWN ..

Yeah, but they will now differ from the spec, which weakens my point
considerably. I guess using KVM_SEV_<spec_name> everywhere is the
optimal solution for the commands and the SEV_STATE_<spec_name> for the
states.

Because having them differ from the spec - esp. for the sake of some
more precise naming - is worse. IMO, of course.

--
Regards/Gruss,
Boris.

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
--

\
 
 \ /
  Last update: 2017-09-06 00:07    [W:0.216 / U:14.532 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site