lkml.org 
[lkml]   [2017]   [Sep]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCHv7 08/19] x86/mm: Make PGDIR_SHIFT and PTRS_PER_P4D variable

* Kirill A. Shutemov <kirill.shutemov@linux.intel.com> wrote:

> #define P4D_SHIFT 39
> -#define PTRS_PER_P4D 512
> +#define __PTRS_PER_P4D 512
> +#define PTRS_PER_P4D ptrs_per_p4d
> #define P4D_SIZE (_AC(1, UL) << P4D_SHIFT)
> #define P4D_MASK (~(P4D_SIZE - 1))

PTRS_PER_P4D_MAX would be a better name than random underscores ...

Thanks,

Ingo

\
 
 \ /
  Last update: 2017-09-28 10:24    [W:0.183 / U:5.148 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site