lkml.org 
[lkml]   [2017]   [Sep]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [lkp-robot] [x86/asm] f5caf621ee: PANIC:double_fault
On Thu, Sep 28, 2017 at 09:59:07AM +0200, Ingo Molnar wrote:
>
> * kernel test robot <xiaolong.ye@intel.com> wrote:
>
> >
> > FYI, we noticed the following commit:
> >
> > commit: f5caf621ee357279e759c0911daf6d55c7d36f03 ("x86/asm: Fix inline asm call constraints for Clang")
> > https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git master
> >
> > in testcase: trinity
> > with following parameters:
> >
> > runtime: 300s
> >
> > test-description: Trinity is a linux system call fuzz tester.
> > test-url: http://codemonkey.org.uk/projects/trinity/
> >
> >
> > on test machine: qemu-system-x86_64 -enable-kvm -m 420M
> >
> > caused below changes (please refer to attached dmesg/kmsg for entire log/backtrace):
> >
> >
> > +-----------------------------------------+------------+------------+
> > | | 0d0970eef3 | f5caf621ee |
> > +-----------------------------------------+------------+------------+
> > | boot_successes | 9 | 4 |
> > | boot_failures | 0 | 4 |
> > | PANIC:double_fault | 0 | 4 |
> > | Kernel_panic-not_syncing:Machine_halted | 0 | 4 |
> > +-----------------------------------------+------------+------------+
>
> I think a key piece of information is that the test is using GCC 4.4:
>
> export compiler='gcc-4.4'
>
> ... which is pretty old compared to what gets tested typically.
>
> GCC 4.4 was released in 2009 (!), the last minor update of 4.4.7 was 5 years ago.

Sure, but its still an officially supported GCC version. So either it
must be made to work, or we must update the minimal GCC version
requirements for the kernel.

\
 
 \ /
  Last update: 2017-09-28 10:19    [W:0.062 / U:9.032 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site