lkml.org 
[lkml]   [2017]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectProblems with Chromebook Pixel 2015 audio
Hey folks,

Entirely unrelated to the regression on this board that we dealt with
the other week, I have (and have had for a bit), a problem with audio on
this laptop. After a while of use, I'll have a problem like this:

Sep 12 20:59:30 oliver kernel: haswell-pcm-audio haswell-pcm-audio: FW
loaded, mailbox readback FW info: type 01, - version: 00.00, build 77,
source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
(everything is fine, audio works, is in use)
Sep 12 21:24:04 oliver kernel: haswell-pcm-audio haswell-pcm-audio:
error: audio DSP boot timeout IPCD 0x0 IPCX 0x0
Sep 12 21:24:04 oliver kernel: haswell-pcm-audio haswell-pcm-audio: ipc:
--message timeout-- ipcx 0x83000000 isr 0x00000000 ipcd 0x00000000 imrx
0x7fff0000
Sep 12 21:24:04 oliver kernel: haswell-pcm-audio haswell-pcm-audio:
error: stream commit failed
Sep 12 21:24:04 oliver kernel: System PCM: error: failed to commit
stream -110
Sep 12 21:24:04 oliver kernel: haswell-pcm-audio haswell-pcm-audio:
ASoC: haswell-pcm-audio hw params failed: -110
Sep 12 21:24:04 oliver kernel: System PCM: ASoC: hw_params FE failed
-110

With those last 4 messages repeating constantly (~3 sets per second, and
the above are from v4.13, but I've had similar for as long as the driver
has been mainline I think) and it only stops when I reboot. Rebooting
may or may not clear the problem, last night I had to power off to get
audio to come back up. I'm not quite sure where to begin debugging this
issue. Does anyone have any suggestions? Thanks!

--
Tom
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2017-09-13 16:56    [W:0.034 / U:0.572 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site