lkml.org 
[lkml]   [2017]   [Sep]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC Part2 PATCH v3 10/26] KVM: Introduce KVM_MEMORY_ENCRYPT_REGISTER/UNREGISTER_RAM ioctl
On Tue, Sep 12, 2017 at 03:50:55PM -0500, Brijesh Singh wrote:
> Sure, I can do that. In one of the feedback Paolo recommended
> KVM_MEMORY_ENCRYPT_* ioctl name hence I tried to stick with the same name
> for structure. I am flexible to use 'struct enc_region' but I personally
> prefer to keep "mem" somewhere in the structure naming to indicate its for
> *memory* encryption -- maybe struct kvm_mem_enc_region.

I'd drop the "kvm_" prefix: struct mem_enc_region;

But I sense we're bikeshedding here and I'd leave it up to you guys.
My only intent was to shorten those so that they fit on a single line.
In general, I like using small struct names which do not look like
sentences and which give you code that reads quickly, at a glance. But
this is just me.

--
Regards/Gruss,
Boris.

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
--

\
 
 \ /
  Last update: 2017-09-12 23:09    [W:0.118 / U:4.876 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site