lkml.org 
[lkml]   [2017]   [Sep]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [Outreachy kernel] [PATCH] Fixed IIO_DEVICE_ATTR_NAMED API to take name as a string and added "" around names
From
Date
On 09/12/2017 08:06 PM, Julia Lawall wrote:
>
>
> On Tue, 12 Sep 2017, himanshi wrote:
>
>> Thanks for the review Daniel! I will change the imperative mood for the commit
>> message once the other changes are finalised too and as suggested by Julia,
>> would try to make the description specific than general.
>>
>> I tried to think of adding subsystem to the commit subject but could not
>> conclude any because of the files involved.
>> I like the idea of splitting the patch into 2 as you suggested but I
>> have a doubt that adding the new MACROS to different sysfs files can be put into 1
>> patch with the subsystem you mentioned but changing the existing
>> IIO_DEVICE_ATTR_NAMED to use IIO_ATTR_NAMED (sysfs file again) would be included
>> in the second patch if I am not wrong. So would it be fine to keep the
>> subsystem as iio for the second patch?
>
> Indeed, the kernel has to compile after every commit. Unless you change
> the name of the macro, to allow the old and new versions to co-exist, it
> seems hard to break up such a patch.

We can still split things into two parts. One patch introducing __ATTR_NAMED
in the device driver core and then another patch making use of that macro in
the IIO subsystem.

\
 
 \ /
  Last update: 2017-09-12 20:14    [W:0.043 / U:0.756 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site