lkml.org 
[lkml]   [2017]   [Sep]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] ARC: reset: remove the misleading v1 suffix all over
From
Date
On 09/11/2017 03:28 AM, Philipp Zabel wrote:
> Hi Vineet,
>
> [added Eugeniy to Cc]
>
> On Thu, 2017-08-31 at 11:06 -0700, Vineet Gupta wrote:
>> There is no plan yet to do a v2 board. And even if we were to do it
>> only some IPs would actually change, so it be best to add suffixes at
>> that point, not now !
>>
>> Cc: Philipp Zabel <p.zabel@pengutronix.de>
>> Signed-off-by: Vineet Gupta <vgupta@synopsys.com>
>> ---
>> P.S. Philip, if you and Eugeniy are OK, can this be please squashed
>> with his original patch since it has not yet been merged etc.
> This had been merged into arm-soc already, and by now is merged into
> mainline. We could try to queue this as a fix for 4.14.

OK - do you want a respin ?

>
> [...]
>> --- a/drivers/reset/Kconfig
>> +++ b/drivers/reset/Kconfig
>> @@ -34,11 +34,11 @@ config RESET_BERLIN
>> help
>> This enables the reset controller driver for Marvell Berlin
>> SoCs.
>>
>> -config RESET_HSDK_V1
>> - bool "HSDK v1 Reset Driver"
>> +config RESET_SNPS_HSDK
> I suggest to drop the _SNPS part, we don't do it for the other drivers
> either, and so far I'm not afraid of conflicts with other reset
> controllers that may be called HSDK.

It was not so much about namespace conflict but calling out that this is SNPS part !
But I'm fine with what you suggest, since the updated menu string does have it.

Thx,
-Vineet

\
 
 \ /
  Last update: 2017-09-11 18:33    [W:0.043 / U:0.384 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site