[lkml]   [2017]   [Sep]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Converting struct timer_list callback argument to struct timer_list *
On Fri, 1 Sep 2017, Christoph Hellwig wrote:

> Good work!
> I just think that the TIMER_CONTAINER name is revolting.
> The usual name for such a helper fitting other uses like lists
> and rbtrees would be timer_entry, and that also reads much better.

I think the plan is to remove that thing afterward, because then the
callback function is:

void func(struct timer_list *timer)

So I don't mind the ugly name as it should be simply removed once the tree
is converted over.



 \ /
  Last update: 2017-09-01 12:22    [W:0.589 / U:3.876 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site