[lkml]   [2017]   [Aug]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 31/31] timer: Switch to testing for .function instead of .data
On Thu, Aug 31, 2017 at 4:59 PM, Kees Cook <> wrote:
> On Thu, Aug 31, 2017 at 4:45 PM, Dmitry Torokhov
> <> wrote:
>> On Thu, Aug 31, 2017 at 4:29 PM, Kees Cook <> wrote:
>>> In several places, .data is checked for initialization to gate early
>>> calls to del_timer_sync(). Checking for .function is equally valid, so
>>> switch to this in all callers.
>> Not seeing the rest of patches it is unclear from the patch
>> description why this is needed/wanted.
> The CC list would have been really giant, but here is the first patch
> and the earlier series list:
> tl;dr: We're going to switch all struct timer_list callbacks to get
> the timer pointer as the argument instead of from the .data field.
> This patch is one step in removing open-coded users of the .data
> field.

And that is exactly what should have been in the patch description.

FWIW for input bits:

Acked-by: Dmitry Torokhov <>



 \ /
  Last update: 2017-09-01 03:07    [W:0.046 / U:17.040 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site