lkml.org 
[lkml]   [2017]   [Aug]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] [media] media: imx: depends on V4L2 sub-device userspace API
Date
This driver uses various v4l2_subdev_get_try_*() functions provided by
V4L2 sub-device userspace API. Current configuration of Kconfig file
allows us to enable VIDEO_IMX_MEDIA without enabling this API. This
breaks the build of driver.

Depend on VIDEO_V4L2_SUBDEV_API to fix this issue.

Signed-off-by: Cihangir Akturk <cakturk@gmail.com>
---
drivers/staging/media/imx/Kconfig | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/drivers/staging/media/imx/Kconfig b/drivers/staging/media/imx/Kconfig
index 7eff50b..d8c3890 100644
--- a/drivers/staging/media/imx/Kconfig
+++ b/drivers/staging/media/imx/Kconfig
@@ -1,6 +1,7 @@
config VIDEO_IMX_MEDIA
tristate "i.MX5/6 V4L2 media core driver"
- depends on MEDIA_CONTROLLER && VIDEO_V4L2 && ARCH_MXC && IMX_IPUV3_CORE
+ depends on MEDIA_CONTROLLER && VIDEO_V4L2 && VIDEO_V4L2_SUBDEV_API && \
+ ARCH_MXC && IMX_IPUV3_CORE
select V4L2_FWNODE
---help---
Say yes here to enable support for video4linux media controller
--
2.7.4
\
 
 \ /
  Last update: 2017-08-14 13:02    [W:0.033 / U:6.188 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site