lkml.org 
[lkml]   [2017]   [Aug]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v2 1/5] reset: add reset-simple to unify socfpga, stm32, sunxi, and zx2967
From
Date
On Fri, 2017-08-11 at 23:51 +0800, Chen-Yu Tsai wrote:
> On Fri, Aug 11, 2017 at 9:06 PM, Philipp Zabel <p.zabel@pengutronix.de> wrote:
> > +static int reset_simple_probe(struct platform_device *pdev)
> > +{
> > +       struct device *dev = &pdev->dev;
> > +       const struct of_device_id *of_id =
> > +               of_match_device(of_match_ptr(reset_simple_dt_ids), dev);
> > +       const struct reset_simple_devdata *devdata = of_id->data;
>
> Just use of_device_get_match_data().

Will do that, thanks.

> > +struct reset_simple_data {
> > +       spinlock_t                      lock;
> > +       void __iomem                    *membase;
> > +       struct reset_controller_dev     rcdev;
> > +       bool                            inverted;
>
> You should document this option. "Inverted" by itself does not
> say a whole lot, as there is no mention about what the normal
> or non-inverted behavior is. Is the reset active low (assert
> reset when bit is cleared)? Or active high (assert reset when
> bit is set)?

You are right. Also, maybe I should rename this to
"bool active_low;" to avoid confusion where it is used.

regards
Philipp

\
 
 \ /
  Last update: 2017-08-11 17:58    [W:0.089 / U:1.332 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site