lkml.org 
[lkml]   [2017]   [Jul]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [git pull] vfs.git pile 11
On Thu, Jul 06, 2017 at 12:45:36PM -0700, Kees Cook wrote:
>
> + if (unlikely(!check_copy_size(addr, bytes, false)))
> + return false;
> + else
> + return _copy_from_iter_full(addr, bytes, i);
>
> Can these be rewritten to avoid the double-negative?

Matter of taste - I've no strong preferences here.

> + might_fault();
>
> Should this be might_sleep()? Just from reading the patch it looked
> like you were adding might_sleep()s in the other cases.

D'oh - shouldn't have written that pull request message before the
first cup of coffee... might_sleep() it is, of course.

\
 
 \ /
  Last update: 2017-07-06 22:18    [W:0.050 / U:3.464 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site