lkml.org 
[lkml]   [2017]   [Jul]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 6/9] mm, page_alloc: simplify zonelist initialization
On Mon, Jul 17, 2017 at 10:19:42AM +0200, Michal Hocko wrote:
> On Mon 17-07-17 09:07:23, Mel Gorman wrote:
> > On Mon, Jul 17, 2017 at 08:06:40AM +0200, Michal Hocko wrote:
> > > On Fri 14-07-17 15:18:23, Mel Gorman wrote:
> > > > Fairly sure that's not what you meant.
> > > >
> > > >
> > > > > pg_data_t *node = NODE_DATA(node_order[i]);
> > > > >
> > > > > - zoneref_idx = build_zonelists_node(node, zonelist, zoneref_idx);
> > > > > + nr_zones = build_zonelists_node(node, zonelist, nr_zones);
> > > >
> > > > I meant converting build_zonelists_node and passing in &nr_zones and
> > > > returning false when an empty node is encountered. In this context,
> > > > it's also not about zones, it really is nr_zonerefs. Rename nr_zones in
> > > > build_zonelists_node as well.
> > >
> > > hmm, why don't we rather make it zonerefs based then. Something
> > > like the following?
> >
> > Works for me.
>
> Should I fold it to the patch or make it a patch on its own?

I have no strong feelings either way but if it was folded then the
overall naming should be easier to follow (at least for me).

--
Mel Gorman
SUSE Labs

\
 
 \ /
  Last update: 2017-07-17 10:59    [W:0.073 / U:0.148 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site