lkml.org 
[lkml]   [2017]   [Jul]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/5] phy: Replace the deprecated extcon API
Date
These patches replace the deprecated extcon API
and remove them from extcon framework.

The patch1 and patch2 were already acked by Kishon Vijay Abraham I.
If patch3/patch4 are reviewed, I'll create the immutable branch
and send the pull request to both usb and phy maintainer.

Chanwoo Choi (5):
phy: qcom-usb-hs: Replace the extcon API
phy: rockchip-inno-usb2: Replace the extcon API
phy: phy-bcm-ns2-usbdrd: Replace the deprecated extcon API
usb: gadget: udc: Replace the deprecated extcon API
extcon: Remove deprecated extcon_set/get_cable_state_()

drivers/phy/broadcom/phy-bcm-ns2-usbdrd.c | 8 ++++----
drivers/phy/qualcomm/phy-qcom-usb-hs.c | 14 +++-----------
drivers/phy/rockchip/phy-rockchip-inno-usb2.c | 10 +++++-----
drivers/usb/gadget/udc/snps_udc_plat.c | 6 +++---
include/linux/extcon.h | 11 -----------
5 files changed, 15 insertions(+), 34 deletions(-)

--
1.9.1

\
 
 \ /
  Last update: 2017-07-17 03:21    [W:0.074 / U:0.048 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site