lkml.org 
[lkml]   [2017]   [Jul]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] i40iw: Simplify code
From
Date
On Sun, 2017-07-16 at 13:09 +0200, Christophe JAILLET wrote:
> Axe a few lines of code and re-use existing error handling path to avoid
> code duplication.

unrelated:

> diff --git a/drivers/infiniband/hw/i40iw/i40iw_pble.c b/drivers/infiniband/hw/i40iw/i40iw_pble.c
[]
> @@ -280,8 +278,7 @@ static enum i40iw_status_code add_bp_pages(struct i40iw_sc_dev *dev,
> (info->pages << PBLE_512_SHIFT));
> if (status) {
> i40iw_pr_err("allocate PBLEs in the PF. Error %i\n", status);

It'd be nice if i40iw_pr_<err|warn|info> were removed and
converted into dev_<err|warn|info> or netdev_<err|warn|info>.



\
 
 \ /
  Last update: 2017-07-16 17:12    [W:0.037 / U:1.736 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site