lkml.org 
[lkml]   [2017]   [Jun]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/7] Driver core: remove class_attrs from struct class
Date
Some more patches that have long been sitting in a local tree...

The class_attrs field in struct class duplicates the same effort that
class_groups implements, so let's finally get rid of the last few users
of this field, and delete it, and the duplicated logic in the driver
core.

Subsystem maintainers, I'm glad to take this series in my driver core
tree, if you just want to ack your respective patches, that's fine with
me.

This series has passed 0-day test-builds from what I can tell.

Greg Kroah-Hartman (7):
uwb: use class_groups instead of class_attrs
scsi: ibmvscsi_tgt: remove use of class_attrs
mtd: use class_groups instead of class_attrs
zram: use class_groups instead of class_attrs
gpio: use class_groups instead of class_attrs
pktcdvd: use class_groups instead of class_attrs
driver core: remove class_attrs from struct class

drivers/base/class.c | 33 ------------------------------
drivers/block/pktcdvd.c | 35 ++++++++++++++++----------------
drivers/block/zram/zram_drv.c | 26 ++++++++++++++----------
drivers/gpio/gpiolib-sysfs.c | 13 +++++++-----
drivers/mtd/ubi/build.c | 16 ++++++++-------
drivers/scsi/ibmvscsi_tgt/ibmvscsi_tgt.c | 5 -----
drivers/uwb/driver.c | 11 +++++-----
include/linux/device.h | 2 --
8 files changed, 55 insertions(+), 86 deletions(-)

--
2.13.1

\
 
 \ /
  Last update: 2017-06-12 01:23    [W:0.873 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site