lkml.org 
[lkml]   [2017]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH 3.10 015/250] KEYS: Change the name of the dead type to ".dead" to prevent user access
    Date
    From: David Howells <dhowells@redhat.com>

    commit c1644fe041ebaf6519f6809146a77c3ead9193af upstream.

    This fixes CVE-2017-6951.

    Userspace should not be able to do things with the "dead" key type as it
    doesn't have some of the helper functions set upon it that the kernel
    needs. Attempting to use it may cause the kernel to crash.

    Fix this by changing the name of the type to ".dead" so that it's rejected
    up front on userspace syscalls by key_get_type_from_user().

    Though this doesn't seem to affect recent kernels, it does affect older
    ones, certainly those prior to:

    commit c06cfb08b88dfbe13be44a69ae2fdc3a7c902d81
    Author: David Howells <dhowells@redhat.com>
    Date: Tue Sep 16 17:36:06 2014 +0100
    KEYS: Remove key_type::match in favour of overriding default by match_preparse

    which went in before 3.18-rc1.

    Signed-off-by: David Howells <dhowells@redhat.com>
    Signed-off-by: Willy Tarreau <w@1wt.eu>
    ---
    security/keys/gc.c | 2 +-
    1 file changed, 1 insertion(+), 1 deletion(-)

    diff --git a/security/keys/gc.c b/security/keys/gc.c
    index de34c29..2e01e23 100644
    --- a/security/keys/gc.c
    +++ b/security/keys/gc.c
    @@ -46,7 +46,7 @@ static unsigned long key_gc_flags;
    * immediately unlinked.
    */
    struct key_type key_type_dead = {
    - .name = "dead",
    + .name = ".dead",
    };

    /*
    --
    2.8.0.rc2.1.gbe9624a
    \
     
     \ /
      Last update: 2017-06-12 01:17    [W:4.064 / U:0.088 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site