lkml.org 
[lkml]   [2017]   [Apr]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [alsa-devel] [PATCH] ASoC: dwc: disallow building designware_pcm as a module
On Fri, Apr 21, 2017 at 12:39:30PM +0200, Takashi Iwai wrote:
> Jose Abreu wrote:

> > Maybe rename to "dwc-i2s.c" and "dwc-pcm.c" (as the folder is
> > called "dwc") and let the module still be called "designware-i2s"?

> Lubomir's patch keeps the module name intact. My point is that rename
> of a file isn't nice to look at the git commit history, so it's better
> to be avoided as much as possible. But in this case, it looks
> unavoidable.

Right. Renaming the source file is the lesser evil, it's possible
people might have the module name in their configuration for their
systems somewhere.
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2017-04-21 12:50    [W:0.045 / U:2.348 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site