lkml.org 
[lkml]   [2017]   [Apr]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [GIT PULL 00/28] perf/core fixes and cleanups
Em Thu, Apr 20, 2017 at 02:10:58PM -0300, Arnaldo Carvalho de Melo escreveu:
> Em Thu, Apr 20, 2017 at 01:29:26PM +0200, Ingo Molnar escreveu:
> > * Arnaldo Carvalho de Melo <acme@kernel.org> wrote:
> > > Em Thu, Apr 20, 2017 at 10:10:49AM +0200, Ingo Molnar escreveu:
> > > > * Arnaldo Carvalho de Melo <acme@kernel.org> wrote:
> > > > Pulled, thanks a lot Arnaldo!
> > > >
> > > > > For this specific pull request the samples/bpf/ was disabled, as 'make headers_install'
> > > > > is failing with the following error, in this case in fedora:rawhide:
> > > > >
> > > > > INSTALL usr/include/uapi/ (0 file)
> > > > > /git/linux/scripts/Makefile.headersinst:62: *** Missing generated UAPI file
> > > > ./arch/x86/include/generated/uapi/asm/unistd_32.h. Stop.
> > > > > make[1]: *** [/git/linux/Makefile:1151: headers_install] Error 2
> > > > > make[1]: Leaving directory '/tmp/build/linux'
> > > > > make: *** [Makefile:152: sub-make] Error 2
> > > > > make: Leaving directory '/git/linux'
> > > >
> > > > Beyond this build fix,
> > >
> > > I haven't checked this lately, will do, hopefully this was already taken
> > > care of by someone dealing with the headers_install code.
> >
> > Ah, sorry, I thought it's a problem introduced by perf - if it's an existing
> > upstream bug then never mind!
>
>
> Now if I try outside the container, on a fedora:25 system, same result:
>
> [acme@jouet linux]$ rm -rf /tmp/build/linux
> [acme@jouet linux]$ mkdir /tmp/build/linux
> [acme@jouet linux]$ make O=/tmp/build/linux allmodconfig
> make[1]: Entering directory '/tmp/build/linux'
> HOSTCC scripts/basic/fixdep
> GEN ./Makefile
> HOSTCC scripts/kconfig/conf.o
> SHIPPED scripts/kconfig/zconf.tab.c
> SHIPPED scripts/kconfig/zconf.lex.c
> SHIPPED scripts/kconfig/zconf.hash.c
> HOSTCC scripts/kconfig/zconf.tab.o
> HOSTLD scripts/kconfig/conf
> scripts/kconfig/conf --allmodconfig Kconfig
> #
> # configuration written to .config
> #
> make[1]: Leaving directory '/tmp/build/linux'
> [acme@jouet linux]$ make O=/tmp/build/linux headers_install
> make[1]: Entering directory '/tmp/build/linux'
> INSTALL usr/include/sound/ (15 files)
> INSTALL usr/include/video/ (3 files)
> /home/acme/git/linux/scripts/Makefile.headersinst:62: *** Missing generated UAPI file ./arch/x86/include/generated/uapi/asm/unistd_64.h. Stop.
> /home/acme/git/linux/Makefile:1149: recipe for target 'headers_install' failed
> make[1]: *** [headers_install] Error 2
> make[1]: Leaving directory '/tmp/build/linux'
> Makefile:152: recipe for target 'sub-make' failed
> make: *** [sub-make] Error 2
> [acme@jouet linux]$
>
> Trying to investigate this further now... Perhaps I'm missing something
> :-\

So, it seems that headers_install needs to have as a dependency the
target that generates those headers (/generated/), as it works if I
actually start building the kernel and then do the headers_install
step.

that or allmodconfig
is broken, probably the former, checking...

- Arnaldo

\
 
 \ /
  Last update: 2017-04-20 20:30    [W:0.080 / U:0.432 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site