lkml.org 
[lkml]   [2017]   [Apr]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v4 1/1] pwm: pca9685: fix gpio-only operation.
On Thu, Apr 20, 2017 at 5:12 PM, Sven Van Asbroeck <thesven73@gmail.com> wrote:
>> Taking above into consideration perhaps sleep is not quite good word
>> at all. By functional description it sounds like latency tolerance to
>> me.
>
> That's true, but the bit description in the chip datasheet is 'SLEEP'.
> (its real function is suspend/low power, but the chip designers called
> it 'SLEEP')
>
> Calling the bit/function something else is likely to confuse someone
> who's reading the driver in combination with the chip datasheet.

Looking again into the patch I have noticed:
1) word 'sleep' is used as a part of a function name;
2) int sleep is used as binary value.

Thus, I would suggest: int sleep -> bool enable (or alike).

Would we agree on that?
--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2017-04-20 17:08    [W:0.057 / U:0.280 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site