lkml.org 
[lkml]   [2017]   [Apr]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: v4.10-rc8 (-rc6) boot regression on Intel desktop, does not boot after cold boots, boots after reboot
On Sat, Apr 15, 2017 at 11:34:47PM +0200, Pavel Machek wrote:
> On Wed 2017-04-12 17:08:35, Frederic Weisbecker wrote:
> > On Mon, Apr 03, 2017 at 08:20:50PM +0200, Pavel Machek wrote:
> > > > > > > > ...1d.7: PCI fixup... pass 2
> > > > > > > > ...1d.7: PCI fixup... pass 3
> > > > > > > > ...1d.7: PCI fixup... pass 3 done
> > > > > > > >
> > > > > > > > ...followed by hang. So yes, it looks USB related.
> > > > > > > >
> > > > > > > > (Sometimes it hangs with some kind backtrace involving secondary CPU
> > > > > > > > startup, unfortunately useful info is off screen at that point).
> > > > > > >
> > > > > > > Forgot to say, 1d.7 is EHCI controller.
> > > > > > >
> > > > > > > 00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI
> > > > > > > Controller (rev 01)
> > > > > >
> > > > > > Ok, I should have access soon to a EeePc 1015CX (which seem to have this controller).
> > > > > > I hope I'll be able to reproduce the issue there. If not, I'm sorry but I'll have to
> > > > > > burden you again :-)
> > > > >
> > > > > Go through more mails. It is only reproducible after cold boot. .. so
> > > > > I doubt it will be easy to reproduce on another machine.
> > > > >
> > > > > Now... I do have serial port, and I even might have serial cable
> > > > > somewhere, but.... Giving how sensitive it is, it is probably going to
> > > > > go away with console on ttyS...
> > > >
> > > > I also tried on an eeepc (which has ICH7/NM10 as well), with your config.
> > > > I even plugged a usb keyboard but even then I have been unable to
> > > > reproduce either :-(
> > >
> > > Ok, give me some time. I'm no longer using the affected machine, so no
> > > promises.
> >
> > Actually someone reported me a very similar issue than yours lately. It's probably
> > the same. And I have a potential fix.
>
> Got the machine back to work -- I guess it will be useful for distcc.
>
> And yes, you seem to have right fix :-).
>
> Tested-by: Pavel Machek <pavel@ucw.cz>

Thanks a lot! I'm posting the fix.

\
 
 \ /
  Last update: 2017-04-20 16:53    [W:0.076 / U:0.080 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site