lkml.org 
[lkml]   [2017]   [Apr]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] blutooth: try to improve CONFIG_SERIAL_DEV_BUS dependency
From
Date
Hi Sebastian,

>> With CONFIG_SERIAL_DEV_BUS=m, the hci_serdev.o file does not actually
>> get built into hci_uart.o as the Makefile doesn't pick it up, leading
>> to a link error with anything referring to it:
>>
>> ERROR: "hci_uart_register_device" [drivers/bluetooth/hci_nokia.ko] undefined!
>> scripts/Makefile.modpost:91: recipe for target '__modpost' failed
>>
>> Changing this in the Makefile would cause another problem when
>> hci_uart itself is built-in and cannot reference symbols from the
>> serdev module.
>>
>> This tries to address both problems by introducing a new hidden
>> Kconfig symbol that controls both the compilation of hci_serdev.o
>> and whether the Nokia driver can be selected. This seems to address
>> the problem for me, though there might be a better way to do it.
>>
>> Fixes: 7bb318680e86 ("Bluetooth: add nokia driver")
>> Signed-off-by: Arnd Bergmann <arnd@arndb.de>
>> ---
>> drivers/bluetooth/Kconfig | 8 +++++++-
>> drivers/bluetooth/Makefile | 2 +-
>> 2 files changed, 8 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/bluetooth/Kconfig b/drivers/bluetooth/Kconfig
>> index 8aafbed9e160..737d93ef27c5 100644
>> --- a/drivers/bluetooth/Kconfig
>> +++ b/drivers/bluetooth/Kconfig
>> @@ -76,6 +76,12 @@ config BT_HCIUART
>> Say Y here to compile support for Bluetooth UART devices into the
>> kernel or say M to compile it as module (hci_uart).
>>
>> +config BT_HCIUART_SERDEV
>> + bool
>> + depends on SERIAL_DEV_BUS && BT_HCIUART
>> + depends on SERIAL_DEV_BUS=y || SERIAL_DEV_BUS=BT_HCIUART
>> + default y
>> +
>> config BT_HCIUART_H4
>> bool "UART (H4) protocol support"
>> depends on BT_HCIUART
>> @@ -89,7 +95,7 @@ config BT_HCIUART_H4
>> config BT_HCIUART_NOKIA
>> tristate "UART Nokia H4+ protocol support"
>> depends on BT_HCIUART
>
> I guess BT_HCIUART dependency is no longer needed
> when we have BT_HCIUART_SERDEV dependency?

if so then we need another patch since I already applied the one from Arnd.

Regards

Marcel

\
 
 \ /
  Last update: 2017-04-20 08:56    [W:0.149 / U:6.904 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site