lkml.org 
[lkml]   [2017]   [Mar]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [PATCH RFC 01/14] block, bfq: introduce the BFQ-v0 I/O scheduler as an extra scheduler
    From
    Date
    > +/**
    > + * bfq_entity_of - get an entity from a node.
    > + * @node: the node field of the entity.
    > + *
    > + * Convert a node pointer to the relative entity. This is used only
    > + * to simplify the logic of some functions and not as the generic
    > + * conversion mechanism because, e.g., in the tree walking functions,
    > + * the check for a %NULL value would be redundant.
    > + */
    > +static struct bfq_entity *bfq_entity_of(struct rb_node *node)
    > +{
    > + struct bfq_entity *entity = NULL;
    > +
    > + if (node)
    > + entity = rb_entry(node, struct bfq_entity, rb_node);
    > +
    > + return entity;
    > +}

    Get rid of pointless wrappers like this, just use rb_entry() in the
    caller. It's harmful to the readability of the code to have to lookup
    things like this, if it's a list_entry or rb_entry() in the caller you
    know exactly what is going on immediately.

    --
    Jens Axboe

    \
     
     \ /
      Last update: 2017-03-08 00:25    [W:4.111 / U:0.008 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site