lkml.org 
[lkml]   [2017]   [Mar]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2] x86: s/READ_ONCE_NOCHECK/READ_ONCE/ in arch_atomic[64]_read()

* Dmitry Vyukov <dvyukov@google.com> wrote:

> Two problems was reported with READ_ONCE_NOCHECK in arch_atomic_read:
> 1. Andrey Ryabinin reported significant binary size increase
> (+400K of text). READ_ONCE_NOCHECK is intentionally compiled to
> non-inlined function call, and I counted 640 copies of it in my vmlinux.
> 2. Arnd Bergmann reported a new splat of too large frame sizes.
>
> A single inlined KASAN check is very cheap, a non-inlined function
> call with KASAN/KCOV instrumentation can easily be more expensive.
>
> Switch to READ_ONCE() in arch_atomic[64]_read().
>
> Signed-off-by: Dmitry Vyukov <dvyukov@google.com>
> Reported-by: Arnd Bergmann <arnd@arndb.de>
> Reported-by: Andrey Ryabinin <aryabinin@virtuozzo.com>
> Cc: Mark Rutland <mark.rutland@arm.com>
> Cc: Peter Zijlstra <peterz@infradead.org>
> Cc: Will Deacon <will.deacon@arm.com>
> Cc: Andrey Ryabinin <aryabinin@virtuozzo.com>
> Cc: Andrew Morton <akpm@linux-foundation.org>
> Cc: linux-mm@kvack.org
> Cc: x86@kernel.org
> Cc: linux-kernel@vger.kernel.org
> Cc: kasan-dev@googlegroups.com
> Signed-off-by: Dmitry Vyukov <dvyukov@google.com>
>
> ---
>
> Changes since v1:
> - also change arch_atomic64_read()
> ---
> arch/x86/include/asm/atomic.h | 15 ++++++---------
> arch/x86/include/asm/atomic64_64.h | 2 +-
> 2 files changed, 7 insertions(+), 10 deletions(-)
>
> diff --git a/arch/x86/include/asm/atomic.h b/arch/x86/include/asm/atomic.h
> index 0cde164f058a..46e53bbf7ce3 100644
> --- a/arch/x86/include/asm/atomic.h
> +++ b/arch/x86/include/asm/atomic.h
> @@ -24,10 +24,13 @@
> static __always_inline int arch_atomic_read(const atomic_t *v)
> {
> /*
> - * We use READ_ONCE_NOCHECK() because atomic_read() contains KASAN
> - * instrumentation. Double instrumentation is unnecessary.
> + * Note: READ_ONCE() here leads to double instrumentation as
> + * both READ_ONCE() and atomic_read() contain instrumentation.
> + * This is deliberate choice. READ_ONCE_NOCHECK() is compiled to a
> + * non-inlined function call that considerably increases binary size
> + * and stack usage under KASAN.

s/this is deliberate choice
/this is a deliberate choice

Also, the patch does not apply to the latest locking tree cleanly, due to
interacting changes.

Thanks,

Ingo

\
 
 \ /
  Last update: 2017-03-27 08:27    [W:0.044 / U:0.792 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site