lkml.org 
[lkml]   [2017]   [Feb]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: [Resend PATCH 2/2] mm/memory_hotplug: set magic number to page->freelsit instead of page->lru.next
From
Date

TAB was replaced to white spaces. So please apply this one.

---
From: Yasuaki Ishimatsu <isimatu.yasuaki@jp.fujitsu.com>
Date: Fri, 3 Feb 2017 15:18:03 -0500
Subject: [PATCH] mm/memory_hotplug: Remove unnecessary code from get_page_bootmem()

The following patch is not applied correctly.
http://lkml.kernel.org/r/2c29bd9f-5b67-02d0-18a3-8828e78bbb6f@gmail.com

So the following unnecessary code still remains.

void get_page_bootmem()
{
...
page->lru.next = (struct list_head *)type;
...

The patch removes this code from get_page_bootmem()
---
mm/memory_hotplug.c | 1 -
1 file changed, 1 deletion(-)

diff --git a/mm/memory_hotplug.c b/mm/memory_hotplug.c
index 7409f25..d67787d 100644
--- a/mm/memory_hotplug.c
+++ b/mm/memory_hotplug.c
@@ -179,7 +179,6 @@ static void release_memory_resource(struct resource *res)
void get_page_bootmem(unsigned long info, struct page *page,
unsigned long type)
{
- page->lru.next = (struct list_head *)type;
page->freelist = (void *)type;
SetPagePrivate(page);
set_page_private(page, info);
--
1.8.3.1
\
 
 \ /
  Last update: 2017-02-03 22:14    [W:0.063 / U:0.692 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site