lkml.org 
[lkml]   [2017]   [Feb]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Outreachy kernel] [PATCH v2 1/2] staging: ks7010: Unnecessary parentheses are removed and also improved coding style.


On Tue, 21 Feb 2017, Arushi Singhal wrote:

> Unnecessary parentheses are removed as reported by checkpatch.pl
> to make coder nicer and to improve readability.
> Also coding style is improved.For example:-
> It's often nicer to read if &(foo[0]) is converted to foo like:
> memcpy(&(ap->bssid[0]), &(ap_info->bssid[0]), ETH_ALEN);
> memcpy(ap->bssid, ap_info->bssid, ETH_ALEN);
>
> Signed-off-by: Arushi Singhal <arushisinghal19971997@gmail.com>
> ---
> Changes in v2:
> - Make the commit message more clearer.
> - And correct the error on line number 116
> in file drivers/staging/ks7010/ks_hostif.c
> changes:-
> ap = priv->current_ap;
> is changed to
> ap = &priv->current_ap;

Is this a fix on top of the kernel that Greg has? Or is it a fix on top
of a patch that you have sent previously? It should be the former, not
the latter. If you need to correct something, you send a patch that does
the whole thing, not just the correction.

Among other things, the commit message in this patch has nothing to do
with the change that is actually performed.

Also, the v2 informations says that you are making the commit message
clearer, but it looks the same as the original one (to my recollection).

Finally, the subject line says that this is patch 1/2. So if you need to
send any correction on it, you need to resend the whole series, not just
the patch that changes. Greg will only apply a complete series at once.

julia

> ---
> drivers/staging/ks7010/ks_hostif.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/ks7010/ks_hostif.c b/drivers/staging/ks7010/ks_hostif.c
> index ba283ab741a7..b643a37fb943 100644
> --- a/drivers/staging/ks7010/ks_hostif.c
> +++ b/drivers/staging/ks7010/ks_hostif.c
> @@ -113,7 +113,7 @@ int get_current_ap(struct ks_wlan_private *priv, struct link_ap_info_t *ap_info)
> int rc = 0;
>
> DPRINTK(3, "\n");
> - ap = priv->current_ap;
> + ap = &priv->current_ap;
>
> if ((priv->connect_status & CONNECT_STATUS_MASK) == DISCONNECT_STATUS) {
> memset(ap, 0, sizeof(struct local_ap_t));
> --
> 2.11.0
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20170221140046.GA15208%40arushi-HP-Pavilion-Notebook.
> For more options, visit https://groups.google.com/d/optout.
>

\
 
 \ /
  Last update: 2017-02-21 15:08    [W:2.000 / U:0.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site