lkml.org 
[lkml]   [2017]   [Dec]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 4.4 89/96] spi: SPI_FSL_DSPI should depend on HAS_DMA
From
Date
On Tue, 2017-11-28 at 11:23 +0100, Greg Kroah-Hartman wrote:
> 4.4-stable review patch.  If anyone has any objections, please let me know.
>
> ------------------
>
> From: Geert Uytterhoeven <geert@linux-m68k.org>
>
>
> [ Upstream commit dadab2d4e3cf708ceba22ecddd94aedfecb39199 ]
>
> If NO_DMA=y:
>
>     ERROR: "bad_dma_ops" [drivers/spi/spi-fsl-dspi.ko] undefined!
>
> Add a dependency on HAS_DMA to fix this.
[...]

This driver did not use DMA before 4.10, so I think this should be
reverted in the 4.4 and 4.9 branches.

Ben.

--
Ben Hutchings
Software Developer, Codethink Ltd.

\
 
 \ /
  Last update: 2017-12-07 21:42    [W:0.459 / U:16.960 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site